Ford Mondeo ST Forum banner
1 - 9 of 9 Posts

Registered
2002 Mk3 mondeo st220
Joined
12 Posts
Discussion Starter · #1 ·
Here i am again 馃檲
Ok so, driven my car a few times today absolutely no issues with starting, then an hour ago i was about to go home, car cranks over but will not start 馃, what could have happened?
Please if anyone has any clue please let me know 馃檹 馃檪
 

Administrator
Joined
11,448 Posts
You're not having much luck are you.

This could be a number of things, various temperature sensors, fuel pump, fuel rail pressure/pressure sensor, fuel filter.

It might be worth seeing if there are any codes stored in the ECU.

My favourite would be a split coil pack through as they are prone to splitting open at the age most are now.
 

Registered
2002 Mk3 mondeo st220
Joined
12 Posts
Discussion Starter · #3 ·
You're not having much luck are you.

This could be a number of things, various temperature sensors, fuel pump, fuel rail pressure/pressure sensor, fuel filter.

It might be worth seeing if there are any codes stored in the ECU.

My favourite would be a split coil pack through as they are prone to splitting open at the age most are now.
No im really not lol 馃檲
First thing i did was plug the obd reader in and there are no fault codes stored or pending, is thrown me as its been starting absolutely fine with no issues.
Ive had cars with broken down coil packs before and the car still starts or are the mondeo's a bit different if this happens?
Thankyou appreciate you replying to me 馃槉
 

Administrator
Joined
11,448 Posts
Yes and no, depends how badly broken they are. Misfire is the normal sign on these of a broken coil pack, but non starting when warm has been noted as well.

Scratch that for now.

Looking back through the older threads, the camshaft position sensor has been noted for warm/hot start issues on more occasions than other reasons I listed above.

Maybe that is worth a poke around 1st.
 

Registered
2002 Mk3 mondeo st220
Joined
12 Posts
Discussion Starter · #6 ·
Thankyou for the info Neil 馃槉
I have found the culprit today, my fuel pump has stopped working, so i have managed to order a replacement so should be back on the road Wednesday by the latest, if all goes well with me fitting it , which i am not looking forward to 馃槄馃槀
 
1 - 9 of 9 Posts
Top